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Analysis of Gene Expression Data using EPIG
(Extracting Patterns and Identifying co-expressed Genes)

Launching ExP

Double click on the EPIG.bat file (dated 10/30/2009). The Expression Predictor dialog
box will launch. See below.

Data Format

The gene expression data must be relative change in a fixed/standard tab-delimited text

&% Expression Predicior

NIEHS

Expression
Predictor

SVN Normalization

| | Load Compiled Expression |

Pre-process Litility

| | EPIG

format:
First row: unique array name
Second row: names for replicate groups
First col: probe ID or gene accession
See below:
Probe betweenG_1 1 |betweenG_1 2 |betweenG 2 1 |betweenG 2 2 |betweenG_3 1 |betweenG_3 2
replicate betweenG_1 betweenG_1 betweenG_2 betweenG_2 betweenG_3 betweenG_3
A 42 P534203 4.18 3.14 1.91 2.39 1.24 1.02
A 43 P22195 2.47 2.56 2.54 1.84 1.17 0.61

Convert Intensity Data to Relative Change

If the data is single channel intensity data (Affymetrix or Agilent for example), the data

must be converted to relative change using intensity measurements from a baseline




experiment, control sample or sham group. Otherwise, skip to the Load Relative
Change Data section.

Click the Load Compiled Expression button. The data set will appear in a table. See
below.

&% Transpose of text_file_GC_RMA_median_polished_data_s... g@g|
File Analysis Data Help

Sample Hame Row (size): ,E Data Start Column: ,E

Bio Replicate Row(n above threshold): [1_| Data Start Row: [-1_|
Cy3/Cy5 Label Row(r threshold): [-1 | CellLine Name Row: [1_|

Tech Replicate Row (column number): ,E Cell Line Profile Row: ,E

rClick on Column and Select Column Name

colurmn 0 column 1 column 2 column 3 column 4 col
Lahel 0265_456_... |9266_456_... [9267_456_... [9262_456_. |92( 4]
Replicates 07-09 hra 07-09 hra 07-09 hra 049-11 hrs 4=
1616608_a_at |12.0785 11.2104 10.8738 12.0148 11,
1622892_5_at |9.48809 9.23664 8.83401 8.07517 8.3
1622893 _at 3.5569 2.29329 2.30735 2.31343 2.2
1622894 _at 2. 76462 258843 285363 341288 3.0
1622895 _at 10.1411 101684 10.0474 963875 9.6
1622896_at 3.54008 310347 3.54018 4.13696 5.7
1622897 _at 4.48348 448726 4.50297 4.50707 4.4
1622898_a_at |11.3885 11.6643 12,1448 11.9137 11+
[«] i [»]

Highlight by clicking the first cell under “column 1”, right click and choose the “Select
Data Start Column” option. The “Data Start Column” box value should switch from -1 to
1. Next, highlight by clicking the very first cell (upper most left) with a data value, right
click and choose the “Select Data Start Row” option. The “Data Start Row” box value
should switch from -1 to 2. Finally, highlight by clicking a cell in the row with the name
of one of the replicate samples (i.e. 07-09 hrs in the figure above), right click and choose
the “Replicate Row” option. The “Bio Replicate Row” box value should switch from -1
to 1.

From the menu option select Data—>Row Data Processing—>Numerical
Processing—> Subtract First Replicate Average.

&% Transpose of text_file_GC_RMA_median_polished_data_s...

File Analysis |Data | Help e e
5 - - | & 100%
Data Operations Pl Niata Start Columne 1 | o A w =)
N N Row Data Processing # Highlight Row Containing Zero  —
Bio Replica J
Column Data Operations | Highlight all values less =
Cy3 Data Sets Venn Diagrams #| highlight one value less J
Tech Replic Utility | Highlight Missing Value Row J )
B 3% s PR

Profile Similarity in Patterns

( Click on Column and Select Column Name |

Profile Statistical Analysis
column O column 1 column 2
Label 5265_456_.. |9266_458_ | Factor Analysis g
Replicates 07-03 hrs 07-09 hrs Dye Label » j
1616608_a_at_[12.0785 11.2104 Cell Line N
1622892_s_at |3.48808 923664 -
1822893_al _ [3.5564 22829 Pr C
1622834 _at 2.76462 258853 Numerical Processing M Derivative
1822895 &t  [10.1411 10.1684 LINESES ERELTE] 96| Subtrac st I e
1622686_at__ [3.54008 310347 354018 4.13686 5.7
1622807 al  |4.48348  |948726  [s60287  |a.6070r  |s.4)| Sublractrepiverage
1622898_a_at |11.3855 11.6643 121449 11.8137 1]«
[« i ]

From the Menu option select File -> Save Data to save the converted data.



Load Relative Change Data

With the data already saved and it is relative change measurements, it can be loaded
directly into ExP for EPIG analysis by clicking the EPIG button option on the ExP splash
screen. Or, if the converted relative change data is in memory as above, from the Menu
option select Analysis -> EPIG. The EPIG analysis dialog box will launch. See below.

€% Extraction of Patterns AND Identification of Genes |'._||'E|rz|
File Action Option

Pattern List

|pruf||e1_1 |v| | Pattern Plot | | Ower Plot |

| Pattern Sawve | | SHR plot | | Spectrum |

| Correlations ‘ | Remove Selected ‘ | First RepAverage Zero |

l’ Pattern Extraction r Gene Categorization

() First Control Average Zero

Z-score filtering: (5.0

Cluster Resolution: |U.8 | | Pattern Extraction

Minimum Cluster Size: |6
SNR Threshold: |25

Cell lines, multiple controls/references/shams adjustment or alignment

You have a case as below.
T1 ctil trt1l  trtl2  trt13...

T2 ctl2 trt21  trt22  trt23...
T3 ctl3 trt31  trt32  trt33...

At each time point, there is a time matched control. Your input file can be like this —



sampleid

Sl

S2

S3

S4

S5

S6

S7

S8

S9

S10

S11

S12

time

T1

T1

T1

T1

T1

T1

T2

T2

T2

T2

T2

T2

trt

Ctl1

Ctl1

Ctl1

Trtll

Trt1l

Trt1l

Ctl2

Ctl2

Ctl2

Trt21

Trt21

Trt21

Genel

Data
start

Genel

You can select (right mouse button click) time row as cell line name row, and trt row as cell line
profile row. Also you select trt row as replicate row.

1)

Then you go to menu Data>Row data processing>cell line>cell line alignment to sham zero. —
this will use the ctl as a baseline (average to be zero and all others adjusted accordingly)within its
own time point. Then you can save the data if you want and run EPIG.

)

Another approach is you go to menu Data>Row data processing>Numerical processing>subtract
first replicate average — in this case the first control group used as a baseline, then run EPIG.

These 2 different approaches will give you different results. Both are interesting. Depending on
your focus, you may use one or both results.

[ Jun_filtered_heart_Sunitinib_normalized_transposed.txt

File Analysis |Data | Help

Data Operati V———
- S ! - Column: |1
Row Data Processing | Highlight Row Containing Zero
Bio Repliq Column Data Operations *| Highlight all values less art Row: |7
cya Data Sets Venn Diagrams »| ighligit one value less nerow: |
Ltility }| Highlight Missing Value Row
Tech . Mile Row: |6
EAE] g *| profile Similarityin Patterns | CHE
Click on Column and Select Column Name | Profile Statistical Analysis
colurmn 0 column 1 colurmn 2 Factor Analysis Hng colurmn B
Thame EA10065_1... [EA10065_1... || Dye Label » JB5_1.. [EAT0065_1..[a]
sample W1 2 Cell Line ¥/ Cell Line Alignment to Shat
tissue Heart Heart
r— TR TR istical P i ¥/ Cell Line Alignment to Shar
dil 0.0 0.0 Mumerical Processing ¥ Cell Line Alignment to Aver
dz su.0 su.0 wu B S ol Line .
aroup 1 1 1 1 3
7463 at |-0.037424812]-0.004324813)0 06407647 _|-0.03232476 |-0.0p Load Cell Cycle Compartm
7455 _at |0.064974785 [0.008424904] 74762 [0.09752464 |-0.01 Reconstitute With Cell Cyc
7455_at |-0.07800007 [0.020400047 5023 |0 N7EGAIBOGLD 5 patween Sub profiles Corr
7460_at |-0.06007423 [0.044075012] 2503 (0070225716 [0 <o First
7461_a 47367086(0.059033394 83163 |-0.0610466 - CIAIEIE o,
7462_at_|-0.0B547451 [0.06127453 7325075 |0.084524018 | -0.15817451 |-0.08357479

1367463 _at |-0.052350996|0.019848824 |0.027249336 |0.00524802. |-0.005651474|0.050848097)
1367464_at_|-0.06404972 [-0.04598998 |0.009860175 |0.10008048 |-016671944 |0.022080421
1367465 at |-0.0031251... |-0.022924423|0.009875298 |0.01617527 |-0.22112465 -0.13202477
1367467 _at |0.13816022 |-0.03084965 |0.12475014 |0.084248725 |-0.0298500060.14054966
1367468 at [0.121424675-0.09152485 |0.029865265 |0.17308521 |-0.13221455 -0.01087474
7469_at |0.00362478. [-0.025876082[0.03762436 |-0.0162760... [0.02382462 [0.04542446
T470_at |-0.108849525/0.03255081 1250687 |0.015050888 -0.06924915 |-0.09974956:
7471_at_-0.064699445(0.017900467 910019 |0.027900696 -0.19075966 |-0.02120018
7472_at_|-0.010424614]-0.051624208(0.07777 F0.0157241821-0.0684244 [0.018175125
1367473 at 01038225174 |0.093725204 -0.0528747 |-0.078874724|-0.027275085-0.03087520
1367477_at_|0.03207493 |0.03727436 |-0.070625305(0.00127506.. | 018252663 |-0.03372530.
1367478_al |-0.03868942 [0.076200485 |0.00780010...|-0.045100212}-0.13348966 |0.011099815
‘1 3‘57432 at |-0.031200409(0.00379943...[0.033889307 |-0.006600244-0.10080065 [0.07518913 | v/
4 I 1»]

EPIG Analysis: Pattern Extraction

The Pattern Extract tab contains an option and fields for parameters that control the
extraction of the significant patterns from the gene expression data:



e First control Average Zero — click this radio button if the first array data
set is a “sham” control or baseline which all the other arrays are compared
to

e z-score filtering - filters those probes/genes profiles which have one or
more data points with z-score larger than the set value

e Cluster resolution - correlation threshold to filter those patterns generated
with the r-value larger than that to another pattern.

e Minimum Cluster size — the number probe/gene profiles to be merged for
generating the patterns

e SNR Threshold - the threshold for the signal-to-noise for the profiles to be
filtered out and thus not used for generating the patterns

Click the “Pattern Extraction” button to generate the patterns. A plot of the extracted
patterns will be displayed (see below).

DYaRYian NN DS
LA [T
e

The patterns are arranged in order from the upper-left corner going right. Leave the
default settings or go to the menu at the top, Action -> Reset to start over and modify the
parameters according to get more or less patterns to be generated. However, from
empirical analysis, the default parameters work well. Go to Action -> Rename Pattern
Name to name the patterns numerically in the Pattern List drop down.

Some patterns will look very similar (i.e. 6 and 10, 9 and 11, 13 and 16). They will likely
have a high correlation value. Click the “Correlation” button to see the pairwise
correlation values in the Message Board dialog box. See below.



Messape Board

0.79288954 1.0 06950458 0.7307569 067089677 0159500996 041037086 024798886 -0.7914782 |~
0.3403344 06950458 10 0.7653934 0.5245207 0B97BETET  -0.033109333 -0.3243777 -0.34570765 |5
0.588281 07307569 07653934 1.0 O16767496 018393864 05294783 -0.076751314 -0.58972293
0.32274702 067089677 05245207 O1E7E7496 1.0 0480755368 -0.28589558 0.0446259 -0.36152065
0.374996 0155009968  0BY7BE7E3  0.19393864  0.48075536 1.0 -0LEE3471 -0.6B377 36 0.27259564
0.74349666  0.41037086  -0.033109333 0.5294783 -0.2858558  -0.B63471 10 0.5735619 -0E1E1712
0.65567696  0.24798886  -0.3243777 -0.076751314 0.0446259 -0.B837736 05735619 1.0 -0.6G39985
089916277 -07914782  -0.34570765  -0.58972293  -0.36152065 0.27259564  -0.6161712 -0.6639985 1.0

D.a194785 -0107E2ZY28 022067894 -0.38123578  0.5885514 074226608  -0.84052946 -0.5132226 0.47542062
07984953 -0.82875437  -0.59602004  -0.8034659 -0.28321652 0037248634 -0.5808825 -0.26019767  0.7889088
0.42425033 -017937848  -061513913  -0.16279803 -0.50017375  -0.95260346  06E99673 0.7401924 -0.31240857
0.a104283 -0.3974954 024086808  -0.164863682 -0.03869681 07881939 -TETI9ITT -0.8393417 0.7424558
oai7age -0.8866073  -0.74107856  -0.6BE6369 -0.630424 -01FTES951  -0.31700006  -0.3004827 0.78730756
025138468 -07046596  -0.8653431 -0.6BTE2827  -0.6462589  -07756052 014925231 0.368088987  0.32431388
0971282 -0.7455766  -0.30232435  -0.5790837 -0.2387012 041646773 -0.7996987 -0.6120081 0.79442596

Click the SNR plot button to see a plot of the SRN for each pattern

pattern SNR

pattern snr plot

g 12

20

. See below.

pattern number

The “Message Board” dialog box displays the SNR values, magnitude of change, SNR p-
value, ANOVA test statistic and ANOVA p-value for each pattern. See below.

& Message Board

Fattern SNR hag SMR_pWalue  ANOWA ANOVA_pValue
1 126879711 4143225 0.000000 0.080079 0.oo00001
2 6.714427 1.580073 0.000077 0.058070 0.0oo0130
3 4 RE2817 1.832069 0.000340 [ERIER Beh B 0.000429
4 6.740316 1.218798 0.000023 0.024522 0.oo00g9
5 6.465257 0.893779 0.000031 0.014333 n0.ooo117
5 43182349 2.080281 0.000672 0174057 0.001355
7 5674582 0.875256 0.000082 0017843 0.000120
&l 5.098265 0841472 0.000177 0.020431 n0.oooz1s
9 4T7TATIE 0.068562 0.000284 0000155 0.0007 36
10 43371749 0901183 0.000555 0.032380 0.000925
11 4.804409 0166823 0.000271 0.000904 0.000834
12 5753014 1.726544 0.000074 0.087450 0.000294
13 4912333 0.889690 0.000232 0.024602 0.000423
14 7220184 0.874827 0.o00014 oot1o11 0.000014
156 4891305 1.203083 0.000235 0052417 0.000309
16 5207103 1.642817 0.000152 0.074653 0.000330

The pattern (of the two similar ones) with the lower SNR (of patterns 13 and 16, pattern
13 has a lower SNR) may be deleted by selecting the pattern from the drop down menu
and click the “Remove Selected” button.

Once you have the number of desired patterns generated, click “Pattern Save” and enter
in a name for a file to be generated which will have the patterns and associated parameter
values stored in it. See below.



E Save a File gl
Look In: ||j EPIG "| E

[ help

3 Source_code
[} Dummybata.txt
[ mySavetxt

D readme.t=t

File Hame: |myPaﬂernSave.bd |

Files of Type: |Text Files (txt)

|"

EPIG Analysis: Gene Categorization

Click the Gene Categorization tab (see below).

&% Bxraction of Patterns AND Identification of Genes
File Action Option

rPattern List
|pr0ﬁ|e1_1 | - ‘ | Pattern Plot | | Over Plot |
| Pattern Save ‘ | SNR plot | | Spectrum |
| Correlations ‘ | Remove Selected | | First RepAverage Zero |

r Pattern Extraction r Gene Categorization |

itude [0.5

@ AND OSNR 3

) ANOVA pvalue  [0.001

|

|

) Mag*{-log10 p¥alue) ® SNR p¥alue |I] 001 ‘
|

|

r-value |g_a

| Display Selected Genes |

This tab contains parameters that control the binning of probes/genes to the patterns that
were generated:

e Magnitude (S) — the amount of variation in gene expression within

profiles.
maz{ G}, if min{&;} > 0
8 =3d-minl{g; |, elseifmax{g;| <0
mar{ g} - min{g;} otherwise

where % is the intra-group average.


http://www.biomedcentral.com/render/render.asp?equation=1471-2105-8-427-i3
http://www.biomedcentral.com/render/render.asp?equation=1471-2105-8-427-i1

e SNR - the signal to noise ratio for the profile

-z
SNE /4
where S is denoted above,
o 2
2| i-0sF | m
= (! *
N = — Z -
RTERY f
!
and the sample variance is
ny _
z (2j-3i )
F-d—
e -1

¢ SNR p-value - the significance level for the SNR
e ANOVA p-value - the significance level for an ANOVA of the profile
e r-value — the correlation value for the profile to be similar to the pattern

From empirical analysis, the default parameter settings work well. To adjust the settings,
enter a value for Magnitude, click “And”, click the radio button and enter a value for
either SNR, SNR p-value or ANOVA p-value, and then enter an r-value. Click
Mag*(log10pvlaue) of you want to use the John Zheng modification for categorization of
the profiles to the patterns that takes into account both the magnitude of change and the
p-value.

Click “Display Selected Genes” to launch up to three dialog boxes as tables with the
probe/gene profiles categorized to the patterns, the probe/gene profiles not categorized to
particular patterns and the probe/gene profiles categorized to patterns but have low
correlation. See below.


http://www.biomedcentral.com/render/render.asp?equation=1471-2105-8-427-i6
http://www.biomedcentral.com/render/render.asp?equation=1471-2105-8-427-i4
http://www.biomedcentral.com/render/render.asp?equation=1471-2105-8-427-i5

le  Analysis  Plot

8 ProheName  Paitenbame Carrelation Pattentlame2 Correlation2
il 1 IR AEd Linemfile lnn7ed 2464

profiled|profiles =
pruﬂ\eipruﬂleﬁ File Analysis Plot
Pproﬂ\eiproﬂleﬁ ProbeMame  PattenMame ‘Correlation Patteniame? Correlation2
profilefiprofiles forofiled_3 profiled_3 0.9787351 profile3_15 0.28040528 |~
profilef|profiled fprafiled_11 profiled_3 09643404 profiles_15 0.13587865
profilefiprofile forofiled_12 profiled_3 089567176 profile2 15 0.26424375
fllprofilefprofiles farofiled_13 profiled_3 0.9548844 |profile3 15 0247025895
profilediprofiled fprofiled_8 profiled_3 0 9545018 profiles_15 0.18436706
profilefiprofiled forofiled_3 profiled_3 09419538 profiles_15 0.13612929
profilef|profiled fprofiled_15 profiled_3 09386821 profiles_15 0.2231946
profiled §profiled_10 profiled 3 093783736 profile2 15 0.28002425 =
profiled fprofiled_1 profiled_3 0.9373864 |profile3 15 0.21644679
[profile §profiled_5 profiled_3 09303811 profiles_15 0.1854822
profiled §profiled_2 profiled_3 09264649 profiles_15 0.21234453
profileB fprofiled_14  |profiled_3 05209685 profied_15 0 20073581
profiled 6 profiled_3 0.9187576 profile3 15 0.11274975
Jorofiled_7 profiled_3 0.9147492 |profiles_15 0.29177287
profiled_4 profiled4_3 088901716 profile3_15 0.17001256
profiled _4 profiled _4 096431965 profilez_8 020224302
profiled _14 profiled _4 0.8525706 profilez_8 01758896
profile] _6 profile!_4 0.9517625 profile? g 0.11423963
Jorofiled_2 profiled _4 0.9426026 |profile2 8 0.26239842
profile] 1 profile!_4 09416231 profile? 8 013930994
profile] _11 profile] _4 0.93815035 profile2_& 010142314
profilel _13 profiled _4 0.835067 profilez_8 018378336
profile] _10 profile!_4 0.93412393 profile? g 0.0857311
profilel _15 profiled _4 0.9340803 |profile2 8 0.032482482
IErnﬂIe173 profile]_4 093304914 profile? 8 016129197
|pruﬁ|e1_1 o profiled _4 09289151 profilez_8 010512078
profile1 _7 profiled _4 0.82851657 profilez_8 012403736
Pprofile] _& profile!_4 0.9070308 profile? g 0.18210088
—Jorofilel & profiled _4 0.905518 lprofile2_& 0.13832144 |+
4] ] [v]

Click “Spectrum” to launch a dialog box as a table with the probe/gene profiles
categorized to the particular pattern in the drop down list.

For any of the tables, from the menu go to File -> Save Data or Save in Separate Files to
save the probe/gene profiles categorized to patterns. See below.

here are 60 selected genes are correlated..

File | Analysis Plot

Save Data E Correlation Pattenhame2 Carrelation2
Save in Seperate Files 0.9787351 nrofile3_15 0.28040528 |~

0.9643404 nrofiles_15 0.13587865

Close 0.957176 rafle3_15 0.26424375
profiled 13 |profiled_3 0.6545544 profile3_15 0.74702895
profiled_8 profiled_3 0.9545018 profile5_15 018436706
profiled_9 profiled_3 0.94158538 profile5_15 013612929
profiled_15 profiled_3 09386821 profile5_15 0.2231946
profiled_10 profiled_3 0.937837 36 profiled_15 0.28008435 |=
profiled _1 profiled_3 0.9373864 profile3_14 0.21644679
profiled o profiled_3 0.9303811 nrofiled_14a 0.185483232
profiled 2 profiled_3 0.9264649 nrofiled_14a 0.21234453
profiled 14 profiled_3 0.9209695 nrofile3_15 0.20073591
profiled_& arofiled_3 08187576 profiled_15 011274975
profiled_7 arofiled_3 08147492 profiles_15 028177387
profiled_d4 arofiled_3 088901716 profile3_15 017001 356
profile1_4 profile_4 0.96431365 profile2_8 0.20224302
profile1_14 profile_4 0.9525706 profile2_8 01758896
profile1 _6 profile_4 09517625 profile2_8 011423963
profile1_2 profilel_4 0.9426026 profile2_8 0.26239842
profile1_1 profilel_4 0.9416231 profile2 g8 0.13930994
profile1_11 profilel_4 0.93815035 profile? g8 0.10142314
profile1_13 profilel_4 0.935067 nrofile2 8 0.18379326
profile1_10 profilel_4 0.93412393 nrofile2 & 0.0997311
profilel_15  |promlel_4 08340803 profile?_a 0.032482463
profiled_3 arofile]_d4 063304014 profile?_s 016128197
profile1_12 profile1_4 0.9289151 profile?_8 010512078
profile1_7 profile_4 0.92851657 profile2_8 012403726
profile1_5 profile_4 0.9070308 profile2_8 018210088
profile1_8 profilel_4 0905518 profile2_8 013832144 |« |
[T |»]

If saving to separate files, the file names will be generated automatically (such as
selectedGenesInPattern_2_261.txt) and saved in the working directory for EPIG. This is

10



file name contains the pattern number (#2) and the number of probes\genes (n=261)
categorized to it.

Reference:
Chou JW, Zhou T, Kaufmann WK, Paules RS, Bushel PR. Extracting gene expression

patterns and identifying co-expressed genes from microarray data reveals
biologically responsive processes. BMC Bioinformatics. 2007 Nov 2;8:427
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