Home » OIT » ePrint upgrade requires downloading new software

ePrint upgrade requires downloading new software

Duke’s Office of Information Technology is upgrading its ePrint software to improve functionality and add new features. All ePrint users should download and install the new ePrint client at oit.duke.edu/software (search for printing software by computer type). For full information, visit: http://oit.duke.edu/news/2015/2015_06_29eprint.php


Leave a comment

Your email address will not be published.

Archives